Uderc programming article aggregator sites

HELP! Can not install Oracle 8.1.5 w/ RedHat 6.1!

Tags:
Answers: Have 7 answers
Advertisement
I can not get Oracle 8.1.5 to install onto Linux RedHat 6.1. The
Oracle installation script generates several errors. I have
tried several attempts, using different options, but they all
generate errors.
Please help. The Oracle Installation scripts appear to be very
buggy... or perhaps they are incompatible with the standard
RedHat 6.1 release. Either way, it is very frustrating.
I have documented one of my (failed) installation attempts below.
Does anyone have any words of wisdom?
I am installing Oracle onto a Dell Latitude CPi PC w/ 128MB RAM,
a 366MHz Pentium II, and RedHat 6.1 (using the standard Linux
2.2.12-2 kernel). RedHat was installed using the standard "Gnome
Workstation" configuration.
The Oralce CD is labeled:
"Oralce 8i Enterprise Edition
Release 8.1.5
for Linux
(c) Oracle Corporation 1999"
I got this CD about one week ago at Oracle OpenWorld '99 in Los
Angeles... it should be their "latest & greatest" version so far.
1. Pre-Installation and ./runInstall
I created an "oracle" Unix account w/ groups "oinstall" (the
primary group) and "dba" (a secondary group).
I created directories /u01 through /u04, belonging to oracle.
I setup .cshrc and sourced it, containing:
umask 022
setenv DISPLAY `hostname`:0
xhost +
setenv ORACLE_BASE /u01/app/oracle
setenv ORACLE_HOME ${ORACLE_BASE}/product/8.1.5
setenv ORACLE_SID cprtest
setenv PATH ${ORACLE_HOME}/bin:${PATH}
setenv LD_LIBRARY_PATH ${ORACLE_HOME}/lib
setenv NLS_LANG US7ASCII
I downloaded jre116_v5 and installed to /usr/local/jre.
Finally, I executed (from the "oracle" Unix account):
cd /mnt/cdrom
./runInstall
Problem: I got the error (from ./runInstall):
Initializing Java Virtual Machine from /usr/local/jre/bin/jre.
Please wait...
Error in CreateOUIProcess(): -1
: Bad address
Workaround: Executed the following commands instead:
cd /mnt/cdrom/install/linux
./runIns.sh
3. runIns.sh and root.sh
I selected the following options (from ./runIns.sh):
Source: /mnt/cdrom/stage/products.jar
Destination: /u01/app/oracle/product/8.1.5
Oracle 8i Enterprise Edition 8.1.5.0.0
Typical (585MB)
Installable Components: Oralce Intelligent Agent 8.1.5.0.0
Global Database Name: cprtest.parkrussell.com
SID: cprtest
Directory for Database Files: /u02
Then (when instructed by ./runIns.sh), I attempted to execute
(from the
"root" Unix account):
cd /u01/app/oracle/product/8.1.5
./root.sh
Problem: I got the error:
"bash: ./root.sh: Permission denied"
The execute bit was not set.
Workaround: I executed:
chmod a+x root.sh
./root.sh
5. Configuration Tools
The Oracle Installer (./runIns.sh) attempted to execute:
A. Net8 Configuration Agent
B. Oracle Database Configuration Agent
Problem: The "Oracle Database Configuration Agent" failed with
the following error message:
"One or more tools have failed. It is recommended but not
required that these tools succeed for this installation.
You can now select these tools, read its details to examine
why they have failed, fix those problems, and retry them.
Or, you can click "Next" to continue."
When I selected the "Oracle Database Configuration Agent" for
more info, I got the following additional details (as the cause
of the error):
"A required command line argument is missing."
The log file
"/u01/app/oracle/oraInventory/logs/installActions.log" recorded:
"Command which is being spawned is /usr/local/jre/bin/jre
-Duser.dir=/u01/app/oracle/product/8.1.5/assistants/dbca/jlib
-classpath
/usr/local/jre/lib/rt.jar:/u01/app/oracle/product/8.1.5/jlib/ewt-3_1_10.jar:/u01/app/oracle/produc
/8.1.5/jlib/share-1_0_6.jar:/u01/app/oracle/product/8.1.5/assistants/dbca/jlib/DBAssist.jar:/u01/a
p/oracle/product/8.1.5/assistants/jlib/jnls.jar:/u01/app/oracle/product/8.1.5/assistants/jlib/ACC.
AR:/u01/app/oracle/product/8.1.5/jlib/help-3_0_7.jar:/u01/app/oracle/product/8.1.5/jlib/oracle_ice
4_03_3.jar:/u01/app/oracle/product/8.1.5/jlib/HotJavaBean.jar:/u01/app/oracle/product/8.1.5/jlib/n
tcfg.jar:/usr/local/jre/lib/i18n.jar
DBCreateWizard /createtype seed /numusers NO_VALUE /apptype
NO_VALUE /cartridges NO_VALUE /options NO_VALUE /demos NO_VALUE
/seedloc NO_VALUE /sid cprtest /orahome
/u01/app/oracle/product/8.1.5 /orabase /u01/app/oracle /dbloc
/u02 /clususer NO_VALUE /cluspswd NO_VALUE /nodeinfo NO_VALUE
/gdbName cprtest.parkrussell.com
Invalid Exit Code. The following result code will be used for
configuration tool: 1
Configuration tool Oracle Database Configuration Assistant
failed"
Workaround: There is obviously nothing I can do to fix this
problem. It appears to be an internal bug in ./runIns.sh.
Therefore, I selected "Next" and executed "dbassist" directly.
6. dbassist
I executed:
dbassist
Problem: I got the following error:
"JNLS Execution:oracle.ntpg.jnls.JNLSException
Unable to find any National Character Sets. Please
check your Oracle installation."
Workaround: Press "OK" and ignore the error.
7. dbassist (cont.)
I selected the following options:
Create database
Typical
Copy existing database files from the CD
Global Database Name: cprtest.parkrussell.com
SID: cprtest
Problem: I got the following error:
"CD-ROM drive not detected on this system.
Database not created."
(Note: I've been running the installation scripts from the
CDROM drive this entire time. "df" shows the CDROM drive
mounted on /mnt/cdrom. "ls /mnt/cdrom" works too.)
Workaround: Abort (which generated the additional error: "Unable
to create database. DBCA-00003: No CD-ROM drive detected.") and
run dbassist again, this time using different parameters.
8. dbassist, again
I executed "dbassist" again and selected the following options:
Create database
Typical
Create new database files
Hybrid
Concurrently connected users: 5
Options: Oralce interMedia, Oralce JServer, and iM demos
Global Database Name: cprtest2.parkrussell.com
SID: cprtest2
Create database now
Problem: I got the following error:
"ORA-01012: not logged on"
Workaround: Try, try again.
9. dbassist, one last time
Executed "dbassist" once more and selected the following options:
Create database
Typical
Create new database files
Hybrid
Concurrently connected users: 5
Options: Oralce interMedia, Oralce JServer, and interMedia
demos
Global Database Name: cprtest3.parkrussell.com
SID: cprtest3
Output creation script
Then, I executed (from the "oracle" Unix account):
cd /u01/app/oracle/product/8.1.5/install
setenv ORACLE_SID cprtest3
./sqlcprtest3.sh
Problem: I got the following output:
"Oracle Server Manager Release 3.1.5.0.0 - Production
(c) Copyright 1997, Oracle Corporation. All Rights Reserved.
Oracle8i Enterprise Edition Release 8.1.5.0.0 - Production
With the Partitioning and Java options
PL/SQL Release 8.1.5.0.0 - Production
SVRMGR> SVRMGR> Connected.
SVRMGR> ORACLE instance started.
ORA-01012: not logged on
SVRMGR> 2> 3> 4> 5> 6> 7>
8> 9> CREATE DATABASE "cprtest3"
ORA-01012: not logged on
SVRMGR> Disconnected."
Workaround: Beats me.
10. sqlplus
I attempted to execute sqlplus, but got the following error
message:
"/u01/app/oracle/product/8.1.5/bin/sqlplus: Permission denied."
The execute bit was not set.
Workaround: I executed:
chmod a+x /u01/app/oracle/product/8.1.5/bin/sqlplus
sqlplus
I gave up for now... there were just too many things wrong with
this installation, starting with the very first command I was
supposed to execute (./runInstaller).
I can't fathom why Oracle's installation script has so many bugs.
Am I just doing something terribly wrong?
Please help.
null
Advertisement
The best answer: I'm using enlightenment version 0.15.5-41, which is more recent
than the 0.15.5-37 version (containing the Oracle installer
patch) that you recommended. Unfortunately, it fails when using
this version.
I also tried installing Oracle using twm, with enlightenment
disabled. This didn't help either.
Furthermore, the errors that I'm encountering in the OUI are
not just toward the end of the installation. They happen from
the very beginning, right after I enter "./runInstall", and
continue every step of the way.
Calvin Mitchell (guest) wrote:
: Check out my thread: "Assistants Failure Toward end of Oracle
: Install" to see where i've gone with this.
: if your running Enlightenment as your window manager you need
to
: upgrade to 0.15.5-37, that will solve the OUI error.
: Let me know if you solve any of your problems.
: Chris Russell (guest) wrote:
: : I can not get Oracle 8.1.5 to install onto Linux RedHat 6.1.
: The
: : Oracle installation script generates several errors. I have
: : tried several attempts, using different options, but they all
: : generate errors.
: : Please help. The Oracle Installation scripts appear to be
very
: : buggy... or perhaps they are incompatible with the standard
: : RedHat 6.1 release. Either way, it is very frustrating.
: : I have documented one of my (failed) installation attempts
: below.
: : Does anyone have any words of wisdom?
: : I am installing Oracle onto a Dell Latitude CPi PC w/ 128MB
: RAM,
: : a 366MHz Pentium II, and RedHat 6.1 (using the standard Linux
: : 2.2.12-2 kernel). RedHat was installed using the standard
: "Gnome
: : Workstation" configuration.
: : The Oralce CD is labeled:
: : "Oralce 8i Enterprise Edition
: : Release 8.1.5
: : for Linux
: : (c) Oracle Corporation 1999"
: : I got this CD about one week ago at Oracle OpenWorld '99 in
Los
: : Angeles... it should be their "latest & greatest" version so
: far.
: : 1. Pre-Installation and ./runInstall
: : I created an "oracle" Unix account w/ groups "oinstall" (the
: : primary group) and "dba" (a secondary group).
: : I created directories /u01 through /u04, belonging to oracle.
: : I setup .cshrc and sourced it, containing:
: : umask 022
: : setenv DISPLAY `hostname`:0
: : xhost +
: : setenv ORACLE_BASE /u01/app/oracle
: : setenv ORACLE_HOME ${ORACLE_BASE}/product/8.1.5
: : setenv ORACLE_SID cprtest
: : setenv PATH ${ORACLE_HOME}/bin:${PATH}
: : setenv LD_LIBRARY_PATH ${ORACLE_HOME}/lib
: : setenv NLS_LANG US7ASCII
: : I downloaded jre116_v5 and installed to /usr/local/jre.
: : Finally, I executed (from the "oracle" Unix account):
: : cd /mnt/cdrom
: : ./runInstall
: : Problem: I got the error (from ./runInstall):
: : Initializing Java Virtual Machine from
: /usr/local/jre/bin/jre.
: : Please wait...
: : Error in CreateOUIProcess(): -1
: : : Bad address
: : Workaround: Executed the following commands instead:
: : cd /mnt/cdrom/install/linux
: : ./runIns.sh
: : 3. runIns.sh and root.sh
: : I selected the following options (from ./runIns.sh):
: : Source: /mnt/cdrom/stage/products.jar
: : Destination: /u01/app/oracle/product/8.1.5
: : Oracle 8i Enterprise Edition 8.1.5.0.0
: : Typical (585MB)
: : Installable Components: Oralce Intelligent Agent 8.1.5.0.0
: : Global Database Name: cprtest.parkrussell.com
: : SID: cprtest
: : Directory for Database Files: /u02
: : Then (when instructed by ./runIns.sh), I attempted to execute
: : (from the
: : "root" Unix account):
: : cd /u01/app/oracle/product/8.1.5
: : ./root.sh
: : Problem: I got the error:
: : "bash: ./root.sh: Permission denied"
: : The execute bit was not set.
: : Workaround: I executed:
: : chmod a+x root.sh
: : ./root.sh
: : 5. Configuration Tools
: : The Oracle Installer (./runIns.sh) attempted to execute:
: : A. Net8 Configuration Agent
: : B. Oracle Database Configuration Agent
: : Problem: The "Oracle Database Configuration Agent" failed
with
: : the following error message:
: : "One or more tools have failed. It is recommended but not
: : required that these tools succeed for this installation.
: : You can now select these tools, read its details to
examine
: : why they have failed, fix those problems, and retry them.
: : Or, you can click "Next" to continue."
: : When I selected the "Oracle Database Configuration Agent" for
: : more info, I got the following additional details (as the
cause
: : of the error):
: : "A required command line argument is missing."
: : The log file
: : "/u01/app/oracle/oraInventory/logs/installActions.log"
: recorded:
: : "Command which is being spawned is /usr/local/jre/bin/jre
: : -Duser.dir=/u01/app/oracle/product/8.1.5/assistants/dbca/jlib
: : -classpath
/usr/local/jre/lib/rt.jar:/u01/app/oracle/product/8.1.5/jlib/ewt-
: 3_1_10.jar:/u01/app/oracle/product/8.1.5/jlib/share-
1_0_6.jar:/u01/app/oracle/product/8.1.5/assistants/dbca/jlib/DBAs
sist.jar:/u01/app/oracle/product/8.1.5/assistants/jlib/jnls.jar:/
u01/app/oracle/product/8.1.5/assistants/jlib/ACC.JAR:/u01/app/ora
: cle/product/8.1.5/jlib/help-
: 3_0_7.jar:/u01/app/oracle/product/8.1.5/jlib/oracle_ice-
4_03_3.jar:/u01/app/oracle/product/8.1.5/jlib/HotJavaBean.jar:/u0
1/app/oracle/product/8.1.5/jlib/netcfg.jar:/usr/local/jre/lib/i18
: n.jar
: : DBCreateWizard /createtype seed /numusers NO_VALUE /apptype
: : NO_VALUE /cartridges NO_VALUE /options NO_VALUE /demos
NO_VALUE
: : /seedloc NO_VALUE /sid cprtest /orahome
: : /u01/app/oracle/product/8.1.5 /orabase /u01/app/oracle /dbloc
: : /u02 /clususer NO_VALUE /cluspswd NO_VALUE /nodeinfo NO_VALUE
: : /gdbName cprtest.parkrussell.com
: : Invalid Exit Code. The following result code will be used
for
: : configuration tool: 1
: : Configuration tool Oracle Database Configuration Assistant
: : failed"
: : Workaround: There is obviously nothing I can do to fix this
: : problem. It appears to be an internal bug in ./runIns.sh.
: : Therefore, I selected "Next" and executed "dbassist"
directly.
: : 6. dbassist
: : I executed:
: : dbassist
: : Problem: I got the following error:
: : "JNLS Execution:oracle.ntpg.jnls.JNLSException
: : Unable to find any National Character Sets. Please
: : check your Oracle installation."
: : Workaround: Press "OK" and ignore the error.
: : 7. dbassist (cont.)
: : I selected the following options:
: : Create database
: : Typical
: : Copy existing database files from the CD
: : Global Database Name: cprtest.parkrussell.com
: : SID: cprtest
: : Problem: I got the following error:
: : "CD-ROM drive not detected on this system.
: : Database not created."
: : (Note: I've been running the installation scripts from the
: : CDROM drive this entire time. "df" shows the CDROM drive
: : mounted on /mnt/cdrom. "ls /mnt/cdrom" works too.)
: : Workaround: Abort (which generated the additional error:
: "Unable
: : to create database. DBCA-00003: No CD-ROM drive detected.")
: and
: : run dbassist again, this time using different parameters.
: : 8. dbassist, again
: : I executed "dbassist" again and selected the following
options:
: : Create database
: : Typical
: : Create new database files
: : Hybrid
: : Concurrently connected users: 5
: : Options: Oralce interMedia, Oralce JServer, and iM demos
: : Global Database Name: cprtest2.parkrussell.com
: : SID: cprtest2
: : Create database now
: : Problem: I got the following error:
: : "ORA-01012: not logged on"
: : Workaround: Try, try again.
: : 9. dbassist, one last time
: : Executed "dbassist" once more and selected the following
: options:
: : Create database
: : Typical
: : Create new database files
: : Hybrid
: : Concurrently connected users: 5
: : Options: Oralce interMedia, Oralce JServer, and interMedia
: : demos
: : Global Database Name: cprtest3.parkrussell.com
: : SID: cprtest3
: : Output creation script
: : Then, I executed (from the "oracle" Unix account):
: : cd /u01/app/oracle/product/8.1.5/install
: : setenv ORACLE_SID cprtest3
: : ./sqlcprtest3.sh
: : Problem: I got the following output:
: : "Oracle Server Manager Release 3.1.5.0.0 - Production
: : (c) Copyright 1997, Oracle Corporation. All Rights
Reserved.
: : Oracle8i Enterprise Edition Release 8.1.5.0.0 - Production
: : With the Partitioning and Java options
: : PL/SQL Release 8.1.5.0.0 - Production
: : SVRMGR> SVRMGR> Connected.
: : SVRMGR> ORACLE instance started.
: : ORA-01012: not logged on
: : SVRMGR> 2> 3> 4> 5> 6> 7>
: : 8> 9> CREATE DATABASE "cprtest3"
: : ORA-01012: not logged on
: : SVRMGR> Disconnected."
: : Workaround: Beats me.
: : 10. sqlplus
: : I attempted to execute sqlplus, but got the following error
: : message:
: : "/u01/app/oracle/product/8.1.5/bin/sqlplus: Permission
: denied."
: : The execute bit was not set.
: : Workaround: I executed:
: : chmod a+x /u01/app/oracle/product/8.1.5/bin/sqlplus
: : sqlplus
: : I gave up for now... there were just too many things wrong
with
: : this installation, starting with the very first command I was
: : supposed to execute (./runInstaller).
: : I can't fathom why Oracle's installation script has so many
: bugs.
: : Am I just doing something terribly wrong?
: : Please help.
null